Joomla 2.5 finally reaches its 'end of life'. Joomla 2.5, which replaced the 1.5 version a few years ago, will no longer be supported as of today (31st December 2014).

If you haven’t already, now is the time to plan to upgrade your site to Joomla 3.x. Joomla 3.x will be supported until at least September 2016.

The most likely difficulties you’ll run in to by updating your version of Joomla are incompatible plugins and possible template inconsistencies. We recommend taking a backup of your site prior to upgrading however if you encounter issues please contact us and we should be able to restore your site from a backup, alternatively contact us about upgrade pricing/options.

If you remain on Joomla 2.5 your website will continue to function as before however it will no longer be considered secure. In 2015, if a weakness is discovered in Joomla 2.5 then hackers may be able to exploit it since the Joomla developers won’t be providing any more security updates. This might not happen and your website could remain stable for years to come, however we prefer you to be aware of the risks so you can decide whether to upgrade now or stick with 2.5 and hope for the best.

Support

We provide technical support to website clients at reasonable rates. We respond to requests and make changes to client websites in a timely manner, 7 days a week.

Contact Us

What is a CMS?

A Content Management System such as Joomla! empowers you to manage your website without the need for additional software and programming expertise.

Learn More